When I run "haxe" on linux => "Segmentation fault (core dumped)"



  • I installed haxe to Linux 64 bit from haxe.org. other things work perfectly (like openfl, haxelib, lime etc...) but when I write "haxe" to the terminal, it says "Segmentation fault (core dumped)"

    gdb output

    Starting program: /usr/bin/haxe 
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
    
    Program received signal SIGSEGV, Segmentation fault.
    0x00007ffff6b79d82 in GC_find_limit_with_bound ()
       from /usr/lib/x86_64-linux-gnu/libgc.so.1
    (gdb) bt
    #0  0x00007ffff6b79d82 in GC_find_limit_with_bound ()
       from /usr/lib/x86_64-linux-gnu/libgc.so.1
    #1  0x00007ffff6b79e5e in GC_init_linux_data_start ()
       from /usr/lib/x86_64-linux-gnu/libgc.so.1
    #2  0x00007ffff6b788d3 in GC_init () from /usr/lib/x86_64-linux-gnu/libgc.so.1
    #3  0x00007ffff6dcf43f in neko_gc_init () from /usr/lib/libneko.so
    #4  0x00007ffff6dcfaee in neko_global_init () from /usr/lib/libneko.so
    #5  0x000000000073532b in ?? ()
    #6  0x00000000004a63d7 in ?? ()
    #7  0x0000000000404889 in ?? ()
    #8  0x0000000000749916 in ?? ()
    #9  0x0000000000749aad in ?? ()
    #10 0x00007ffff7308a40 in __libc_start_main (main=0x737836, argc=1, 
        argv=0x7fffffffde48, init=<optimized out>, fini=<optimized out>, 
        rtld_fini=<optimized out>, stack_end=0x7fffffffde38) at libc-start.c:289
    #11 0x0000000000404169 in ?? ()
    

    How can I solve it? Thanks!

    We are making a MMORPG w/HaxeFlixel => Click Here to go to the Facebook Page

    0




  • @starry-abyss Neko works properly too. Only "haxe" gives error. that topic not solving my problem :P

    I don't create or build a project or something like this. I just write "haxe" to terminal, and get this.

    We are making a MMORPG w/HaxeFlixel => Click Here to go to the Facebook Page

    0


  • So you actually tried to uninstall neko that comes with distro? Or just read the topic and found it irrelevant?



  • @starry-abyss I tried autoremove and nothing happened :/

    (I'm trying with another distro now, my distro may be corrupted.)

    We are making a MMORPG w/HaxeFlixel => Click Here to go to the Facebook Page

    0


  • Last of all:
    1) Install Haxe + Haxelib from packages.
    2) Download haxe binaries.
    3) Copy only "haxe" app (because the haxe came with package is 3.2, this is 3.3)
    4) You got last version of haxe and, not last version but stable haxelib.

    That is what I experienced and found.

    EDIT: FORGET ABOVE.
    THE REAL SOLUTION IS INSTALLING HAXE FROM http://www.openfl.org/download/

    1. Click the "Linux" link.
    2. Extract the .sh file.
    3. If you want to change the haxe version, open the .sh file with any text editor.
    4. Run it.
    5. Enjoy.

    We are making a MMORPG w/HaxeFlixel => Click Here to go to the Facebook Page

    0

Log in to reply