All of my HaxeFlixel Projects stopped working at the same time

  • Hello,

    After spending about a month and a half away from my HaxeFlixel projects, yesterday when I tried running lime test neko, I was met with a whole bunch of errors. I get the same errors on all my HaxeFlixel projects that I try to run through lime, even completed ones. The command 'lime test {anything}' always returns said errors.

    None of the errors have any reference to my code they are all related to lime, openFL and Flixel libraries. I thought that maybe something needed updating and I have tried running 'haxelib update' but that did not fix the problem, only upgrade hxcpp to 4.2.1.

    I have
    Haxe Library Manager 4.0.2
    Lime Command-Line Tools (7.8.0)
    and here is a pastebin to the errors that I keep getting.

    Is there anything else that I can try short of uninstalling and re-installing everything?

    Thank you.

  • What version of Haxe are you using. If you're using 4.2.0 you'll have to downgrade to 4.1.5 for everything to work again.

  • @richardbray I am using 4.2.0, which I guess is the issue. Thank you for your assistance.

  • No worries. I think it was released last week and the other tools .e. Flixel, OpenFL, Lime, haven't had a chance to catch up yet :(

    But they will get there soon 💪

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.