Type not found : flixel.addons.editors.tiled.TiledObjectGroup



  • So what happened to the TiledObjectGroup?
    What is the substitute and how do I work around this issue?
    I didn't see anything in the upgrade guide:
    http://haxeflixel.com/documentation/upgrade-guide-4-0-0/
    (or the previous one)
    Could someone point me in the right direction?
    Thanks!



  • It doesn't seem to exist anymore. It was in a very old version of flixel-addons (1.0.0 - 1.1.0).
    Where did you find/use this class? I suppose that your source code is pretty outdated.



  • If you upgraded openfl or lime recently, you might have to downgrade to last version.

    See this



  • TiledObjectLayer probably?



  • Yeah this is it... mostly my code is pretty outdated. There are LOTS of changes that I need to reconcile.
    Another issue I am facing now is that I used to iterate over tilelayers in my Tiled map, and then load the array of data, but now the TiledLayer doesn't have the 'tiles' property, only TiledTilesLayer...
    Does, TiledLayerType allow me to find out if it is TiledTileLayer? The API docs on that specific are not clear to me what it does.
    Basically I am looping over the TiledLayers, and when I get to the layers with tiles I want to load the map data, when it is the object layers I want to just load those as TiledObjectLayer
    Previously my code worked well... and has done so for a while... however I needed to update the Google APIs, and I upgraded the haxelibs and found a whole set of new issues..
    FlxMath (lots of changes here)
    And now all the tile issues...
    Thanks for the help!



  • You will want to look at the source code of this Tiled Map demo



  • @Israel-

    for (layer in tileMap.layers)
    {
        if (layer.type == TILE)
        {
            // your stuff
        }
    }
    


  • @DleanJeans
    Thank you this explains everything to me
    I now see how it has all changed, very helpful I will be up and running in now time now! :)



  • @starry-abyss
    Thanks so much for the clarity I really appreciate your help here!!
    These changes make more sense now.



  • Now I am getting this odd error....
    I have version 1.9 installed, if I understand this correctly
    java-1.9.0-openjdk-amd64

    -compile:
    [javac] Compiling 6 source files to /path/to/project/export/android/bin/deps/extension-api/bin/classes
    [javac] error: Source option 1.5 is no longer supported. Use 1.6 or later.
    [javac] error: Target option 1.5 is no longer supported. Use 1.6 or later.
    /opt/android-sdk/tools/ant/build.xml:601: The following error occurred while executing this line:
    /opt/android-sdk/tools/ant/build.xml:720: The following error occurred while executing this line:
    /opt/android-sdk/tools/ant/build.xml:734: Compile failed; see the compiler error output for details.

    I have also tried exiting the build.xml file in the sdk directory
    I tried 1.6, 1.7, 1.8, 1.9 and nothing is working (especially 1.9 the one I have, it does not support some option listed)


Log in to reply