'haxe' is not recognized as an internal or external command. But I literally used it yesterday



  • Just like the title states. I'm having trouble running any commands.

    I'm on Windows 8.1

    So here is what I had done yesterday:
    I installed HaxeFlixel just like this website guided. http://haxeflixel.com/documentation/getting-started/
    I upgraded Haxe using haxelib upgrade
    I tried running the hello world tutorial to get the error message Flixel not compatable with openfl 4.0.0
    I ran the command to downgrade both Flixel and Lime

    This is what the end of my environment path looked like when I checked to see if I could fix this myself:
    %HAXEPATH%;%NEKO_INSTPATH%;

    Not understanding how the above works I tried adding the path myself:
    C:\HaxeToolkit\haxe;C:\HaxeToolkit\neko;

    Can someone help me with what I have done wrong?



  • Try restarting HaxeDevelop after changing environment variables. Paths you manually specified look good to me.



  • It works now. The only thing I did was restart my computer and play StarCraft 2.

    The only reason I add StarCraft 2 is because none of this makes any sense.



  • Restarting PC after changing environment variables makes sense. Though restarting the app that uses the variables (HaxeDevelop, cmd.exe, etc) is usually suffice.


Log in to reply