ANDROID: extention-api Source option 1.5 is no longer supported. Use 1.6 or later.



  • Hi I have recently revisited building on Android.
    Here is the build output:

    -compile:
        [javac] Compiling 6 source files to /path/to/export/android/bin/deps/extension-api/bin/classes
        [javac] error: Source option 1.5 is no longer supported. Use 1.6 or later.
        [javac] error: Target option 1.5 is no longer supported. Use 1.6 or later.
    
    BUILD FAILED
    /opt/android-sdk/tools/ant/build.xml:597: The following error occurred while executing this line:
    /opt/android-sdk/tools/ant/build.xml:716: The following error occurred while executing this line:
    /opt/android-sdk/tools/ant/build.xml:730: Compile failed; see the compiler error output for details.
    

    How do I make lime (or whatever) use 1.6 of the extention api, OR use something that will be fine using 1.5
    Anyone else have this issue?



  • Another thing, is this related to the extension-api? What source/target option is being expressed here? I just really need to figure out what I need to be looking for.
    I am using:
    lime 2.9.1
    flixel 4.2.0
    hxcpp 3.3.49
    haxelib 3.2.0-rc3



  • Maybe try to install the lastest Java JDK here (Java SE Development Kit 8u102): Download link



  • @DleanJeans
    Thank you!
    I am actually using openjdk and I had openjdk-9-jdk when I need
    openjdk-8-jdk
    Thank you this was so simple to fix! Your link made it clear I needed the jdk-8 rather than 9 which I had installed.


Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.