Type not found : NMEPreloader



  • When synching my projects via gitHub from my PC to my laptop, all of a sudden I get the following error when trying to compile:

    C:/HaxeToolkit/haxe/lib/openfl/3,6,1/openfl/display/Preloader.hx:172: characters 0-25 : Type not found : NMEPreloader

    Obviously it tries to load an NMEPreloader class which it does not know about. But why? And why only on one machine and not on the other? And why all of a sudden? :confused:

    I'm compiling to flash and all haxeLib libraries are up to date.

    Any ideas?
    Thanks!



  • This even occurs when I create a new and virgin project from the flixel templates.

    The file NMEPreloader.hx is created in my eport/flash/haxe folder each time I try to build the project. Nevertheless, the error is thrown.



  • If you use FlashDevelop (aka HaxeDevelop) you can try removing .hxproj file, which contains absolute paths to libraries on your particular machine, and gets auto-generated from Project.xml anyways



  • Thanks; seemed like a good idea, since I assumed the problems came through the synching between two machines. But it didn't help...
    the problem arises even if I create new projects. It did work on that machine already and I haven't messed with the FlashDevelop settings.

    I did do the upgrade via haxelib though. But how could that be connected?



  • the error occurs in the Preloader-class in line 172:

    #if tools
    typedef OpenFLPreloader = NMEPreloader
    


  • By now I can exclude that it is an error connected to FlashDevelop, as the error also occurs when trying to build the demo projects via the haxeflixel commandline tools. Each and every single project throws the same error.

    It doesn't matter whether I use the dev-version or the 4.0.1 release version of flixel.
    I have deleted and reinstalled the whole haxe package. I've tried it with the nme package installed and without.
    This is my current haxelib list output:

    C:\Users\sano98>haxelib list
    flixel-addons: 2.0.0 git [dev:C:\HaxeToolkit\haxe\lib\flixel-addons/git]
    flixel-demos: [2.1.0]
    flixel-templates: [2.0.1]
    flixel-tools: [1.1.3]
    flixel-ui: [2.0.0]
    flixel: 4.0.1 git [dev:C:\HaxeToolkit\haxe\lib\flixel/git]
    lime-tools: [1.5.7]
    lime: [2.9.1]
    openfl: [3.6.1]

    I'm at my wits end.


  • administrators

    This was actually a regression introduced on the dev branch. It only occured when Git wasn't available on the command line, which made it hard to track down. I just pushed a fix for it, so if you update to latest dev you should be fine:

    https://github.com/HaxeFlixel/flixel/commit/745170b062107ffce3df4b9b6f2180c3e5454284



  • Works for me now! Thanks, Gamma.


Log in to reply