Nape high velocity collision issue ( pinball )

  • Hello,

    I'm trying to create a simple pinball using Nape.
    I started from FlxNapeTilemap example.

    I'm facing an issue where I can't intercept the ball with flippers when it is at high velocity.
    So I set the body of the ball as "isBullet" to have a continuous collision detection, it works, but the drawback is that now the ball is very sticky and has not natural behaviour.

    You can test it here :

    You can set the ball as bullet to see the sticky issue by clicking on the checkbox or test it like it and see the ball pass through the flippers at high velocity (need some tries to reproduce )

    the code :

    Does someone know how to fix this and have a more "natural" behaviour without the messy high velocity collision?


  • One more thing,

    When i lose focus and regain it, the game doesn't continue. It is stuck.

  • Ok I found a workaround : Make a quarter disk as body.

    It's not an elegant solution to me but it works...

    alt text

    Hope it can help someone or if someone has a better idea let me know.

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.