std@module_read issues when building for neko



  • I added some high res images to my game yesterday and since then i can't seem to be building for neko, with the just "std@module_read" showing up on console as an error. I've had the same issues a while ago and based on this and some other resources online have added the lines

    <haxedef name="no-inline" if="neko"/>
    <haxedef name="dce=full" if="neko"/>
    

    to Project.xml as suggested, as well as trying with both neko 2.0 and neko 2.1 but no luck, and I can build just fine on cpp as target but I would prefer to go back to the short neko build times. I know it's got something to do with build size but the game is only 50mb so it shouldn't be that big of a deal.

    This is also probably more of a neko/openfl issue than Haxeflixel, but maybe someone has an idea. I'm probably gonna buy a TexturePacker license and more aggressively reducing the size of my high resolution images in the meantime...



  • I did a bit more testing and turns out it's not just about build size, but about asset size as well. If a file is bigger than 1.25mb~ I get the same error and can't run the game


  • administrators

    That's unexpected, Neko 2.1 should have solved this issue for good, see:

    https://github.com/HaxeFoundation/neko/commit/33a9a460eb9ec8ae64ccb003ac7077a13561619c
    https://github.com/HaxeFoundation/neko/issues/51
    https://github.com/HaxeFoundation/neko/issues/47

    Is there an easy way to reproduce this (perhaps in one of the Flixel demos)?

    I think it might be possible that you're still using Neko 2.0 despite having Neko 2.1 installed / without being aware of it, because OpenFL apparently bundles an older Neko version. There's a very interesting discussion about it here: http://community.openfl.org/t/stand-alone-neko-executables-with-neko/770/21



  • Sorry I couldn't get along to your reply sooner, is there a way of telling which version of Neko is being used or pointing OpenFl the right way?

    All I've done some far is replacing the Neko 2.0 installation files with the Neko 2.1 and at least if I execute "neko" in cmd it does say 2.1.0.

    Thanks.



  • I ended up switching my 200 level thumbnail images to a couple atlas using TexturePacker and that helped me work around this issue

    Still not sure what a proper fix to it would be, tho I'm also not entirely sure what my issue was


Log in to reply