Errors with template-created project



  • Hi, have't use Flixel in a while, tried to make a new project using flixel-tools. Flixel tools version is 1.2.1 and Flixel - 4.2.0, project generated using flixel tpl -n <name> gives errors such as:

    source/MenuState.hx:8: characters 7-26 : Type not found : flixel.util.FlxMath

    and

    source/MenuState.hx:37: characters 2-16 : Not enough arguments
    source/MenuState.hx:35: lines 35-38 : Field update overloads parent class with different or incomplete type
    source/MenuState.hx:35: lines 35-38 : Different number of function arguments


  • administrators

    That sounds like you're using an outdated version of flixel-templates. Since Flixel 4, update() has an elapsed argument that would be missing if you're using a template from before then.

    Simply run:

    haxelib update flixel-templates
    

    And generate a fresh project.



  • Yep, it worked! Thanks! I thought that updating Flixel tools will update it as well.


Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.