Hello World Seg Fault on Linux



    • Flixel version: 4.2.0
    • OpenFL version: 4.8.1
    • Lime version: 3.7.4
    • Linux version: Ubuntu 16.04
    • Affected targets:
      Neko, Flash, HTML5

    I am having trouble running the "Hello World" example provided in the haxeflixel getting started docs.

    Configured flixel-tools with vscode default. Running through the "Hello World" example (http://haxeflixel.com/documentation/hello-world-command-line/) results in a segmentation fault (core dumped) when testing with lime.

    Code snippet reproducing the issue:

    package;
    
    import flixel.FlxG;
    import flixel.FlxSprite;
    import flixel.FlxState;
    import flixel.text.FlxText;
    import flixel.ui.FlxButton;
    import flixel.math.FlxMath;
    
    class PlayState extends FlxState
    {
    	override public function create():Void
    	{
    		super.create();
    		add(new FlxText(0, 0, 0, "Hello World!"));
    	}
    
    	override public function update(elapsed:Float):Void
    	{
    		super.update(elapsed);
    	}
    }
    
    
    lime test neko
    lime test flash
    lime test html5
    

    Observed behavior:
    segmentation fault (core dumped)
    Expected behavior:
    Window with "Hello World" in the title bar.



  • HF currently uses openfl 3.6.1 and lime 2.9.1. You should downgrade those.



  • I downgraded openfl & lime to 3.6.1 and 2.9.1, but I am still getting the same error when running lime test neko.

    flixel: 4.2.0
    lime: 2.9.1
    openfl: 3.6.1



  • @aiokos

    Sorry I can't help more, I'm working with windows.



  • @aiokos
    from Wikipedia, "A segmentation fault occurs when a program attempts to access a memory location that it is not allowed to access, or attempts to access a memory location in a way that is not allowed (for example, attempting to write to a read-only location, or to overwrite part of the operating system)."

    from stack overflow, "A 'segfault' is when a program accesses protected or invalid memory; usually due to poor memory management or buggy pointer manipulation."

    try with flixel: 4.0.1. could be a bug in the software



  • @galoyo Downgrading to 4.0.1 did not fix the issue. I tried the downgraded version with updated versions of lime and openfl as well. I think I will open a Github issue and see if it is related to a bug with the ubuntu package. I have no problems on windows.



  • @dean Thanks for giving it a shot anyways.


  • administrators

    I suggest you check if it works with a pure OpenFL project. You can create one via haxelib run openfl create.


Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.