Problem with building in flash



  • As i try to build the HelloWorld! tutorial windows notifies me that it's impossible to open FlixelTut.swf and asks me to select a program in order to do so
    (i tried selecting "flashplayer_24_sa_debug.exe" and it opens a window actually, but instead of showing "Hello World" on the upper left corner is completely black)
    Which program i should select?

    By the way the Output gives this messages:

    Build succeeded
    Done(0)
    haxelib run lime run "Project.xml" flash -debug
    [No debug Flash player connection request]


  • administrators

    i tried selecting "flashplayer_24_sa_debug.exe"

    That should work. Perhaps you added the "Hello World" text to the wrong state? There are two states, MenuState and PlayState, and PlayState should be used by default.

    Also, what happens when you compile in release mode? You should at least see the HaxeFlixel splash screen then, like at the start of demos (for instance http://haxeflixel.com/demos/Mode/).



  • @Gama11 I wrote it in MenuState, the line before super.create();
    Yes, i have the splash screen when i compile in release mode.
    Ok i pasted the line on PlayState and now it works.


  • administrators

    Try with PlayState instead then.

    I just noticed the information on http://haxeflixel.com/documentation/creating-a-new-project/ is a bit outdated, I'll make sure to fix that.

    In the meantime, the information on http://haxeflixel.com/documentation/hello-world-command-line/ should be accurate.



  • @Gama11 Yes now everything works fine. I just noticed that when i test my project with
    lime test Project.xml neko
    lime test Project.xml html5
    windows shell shows me some warnings:

    C:\Users\rr\Desktop\FlixelTut>lime test Project.xml neko
    export/windows/neko/haxe/ApplicationMain.hx:205: characters 57-75 : Warning : Use programPath instead
    export/windows/neko/haxe/ApplicationMain.hx:80: characters 47-65 : Warning : Use
    programPath instead

    and for html5:

    Warning: Could not find generated font file "C:/HaxeToolkit/haxe/lib/flixel/4,2,1/assets/fonts/nokiafc22.eot"
    Warning: Could not find generated font file "C:/HaxeToolkit/haxe/lib/flixel/4,2,1/assets/fonts/monsterrat.eot"
    Warning: Could not find generated font file "C:/HaxeToolkit/haxe/lib/flixel/4,2,1/assets/fonts/monsterrat.woff"
    Warning: Could not find generated font file "C:/HaxeToolkit/haxe/lib/flixel/4,2,1/assets/fonts/monsterrat.svg"

    As i said everything worked, but i'm worried that this could create me problems in the future.


  • administrators

    You can safely ignore these warnings. :)

    May be a good idea to add some notes about these in the docs too...


Log in to reply