If you are having trouble with lime setup windows or lime setup android

  • I've had this problem for a week and was about to post a question here when it solved itself.
    Since I could find very little help on search engines and forums for this, I'm posting it here in case it helps someone.

    During the Hello World tutorial, in Windows 10, I was having trouble with these steps:
    -->lime setup windows
    -->lime setup android
    both these commands were failing with "Uncaught exception - Blocked"

    -->lime setup windows
    Download and install Visual Studio C++ Express? [y/n/a] ? y
    Downloading vc_web.exe...
    Download complete
    Called from ? line 1
    Called from CommandLineTools.hx line 1400
    Called from CommandLineTools.hx line 25
    Called from CommandLineTools.hx line 94
    Called from CommandLineTools.hx line 1415
    Called from utils/PlatformSetup.hx line 406
    Called from utils/PlatformSetup.hx line 466
    Called from utils/PlatformSetup.hx line 2054
    Called from utils/PlatformSetup.hx line 133
    Called from /usr/lib/haxe/std/haxe/Http.hx line 526
    Called from utils/PlatformSetup.hx line 124
    Uncaught exception - Blocked

    I'm pretty sure this is a connectivity issue. My internet, or server host, who knows. I must have tried this 10 times, but today it worked. I noticed that even when it fails to download fully, it will tell you "download complete". I believe that the uncaught exception is happening when it's trying to install a partial download package. The real tip off was that where before it just seemed to run all at once and fail, today I had to watch the download progress counter, which took a few minutes. After that, everything worked, including "lime setup android".

    I hope this helps somebody.

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.