Interactive debugger

  • So according to the blog post for the release of version 4.2.0 there is supposed to now be an interactive debugger that will let us select and move objects when the debugger overlay is up.

    Only problem is I can't figure out how to use it. I see the little toolbar with the pencil icon that has the select and drag options, but they don't actually do anything when I select them and then click on an object. Maybe I'm missing something obvious. Anyone know how to use this tool?

  • administrators

    Have you tried in one of the demos (like Mode, which is used on the blog post's .gif)? Perhaps it's something specific about your project that makes it not work.

  • I just tried it with the Mode demo and got some interesting results. When I pull up the debugger overlay on the menu state and select any of the interactive options it actually works and I can then select menu objects with the standard mouse cursor. But as soon as it switches to the PlayState the cursor disappears and I can't select anything anymore, similar to the problem I'm having with my own game.

    If the Mode demo is working for everyone else then I don't know what it is that could be causing this. I suppose it's possible it's my set up but I originally set everything up as per the documentation, not doing anything exceptional. I'm on the latest version too.

    Edit: OK, this seems obvious, but I set "FlxG.mouse.visible" to equal true in the playstate and now I can see the mouse and select things. I didn't consider this at first because even with the mouse visibility to false I can still see the mouse with the debugger overlay, only disappearing when I clicked the select button.

    It still doesn't work with some other demos and my own game though, so I'm wondering what's the difference here.

  • administrators

    What target are you testing this on?

  • I've been testing everything on cpp and neko, both the mode demo that worked and the stuff that hasn't been working.

    Edit: Ok, I figured out what's going on, and it's odd. Turns out there are two reasons things weren't working.

    1. Any demo that had FLX_NO_MOUSE defined in Project.xml had had to be removed because you can't select things without the mouse.

    2. But the real problem came from this: it seems I can't select things when the window is maximized. The reason mode worked was that I simply didn't maximize the window when testing it. Often the resolutions for demos and even my own game are so small that I can't view the debug overlay comfortably without maximizing so that's why I never tested it without doing so. I didn't think that would be a factor.

    When neither of these two points are present it works for everything.

  • administrators

    Is the Flash target affected by that "window-maximize-bug" as well?

  • Yeah, same thing with flash. If the window is untouched it works but the moment I stretch it in any way everything becomes unselectable.

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.