"Error Could not find Haxe in PATH. Is it installed?"

  • So I was following the Getting Started documentation, and everything was going just fine. I'm using Visual Studio Code, and it was compiling and running just fine whether it be HTML5, Flash, or Neko. Then, when I closed the IDE and reopened it, I get this error now, and now nothing compiles. I tried updating everything from the command prompt, and although it updated Lime, it didn't solve the issue. Compiling from the command prompt works just fine. When I try to compile it in VS Code, I get "The terminal process terminated with exit code: (1 or 3221225477). What happened?

  • administrators

    • What OS are you on?
    • What does haxe -version print when you open a command prompt?
    • What happens if you do the same from VSCode's Integrated Terminal?
    • Have you tried reinstalling Haxe?

  • I am on Windows 7 Ultimate - Service Pack 1, 64-bit.

    When using the "haxe -version" command in the command prompt, I get "3.4.2 (git build master @ 890f8c7)"

    When I try typing anything haxe related in VS Code's built in terminal, I get the error "'haxe' is not recognized as an internal or external operable program or batch file." Same if I try a command beginning in lime.

    I would rather not have to completely uninstall and reinstall Haxe, but if all else fails, I will.

    Thanks for the response.

  • administrators

    Sounds like Haxe is in your PATH, but for some reason not being picked up by VSCode. What happens if you start code (name of the VSCode executable, might need to add it to PATH first) through the command prompt where haxe -version works?

    You could specifiy the path to Haxe explicitly in settings.json, but this will only work for completion, not compilation:

  • Alright, VSCode detects Haxe when I open it from the command prompt. I can work with this. Thanks.

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.