Type Not Found: Flixel.addons. *



  • Hi. Using VS Code on OS X 10.11.6, I am unable to import anything within the addons library. Specifically I am attempting to import flixel.addons.editors.tiled.TiledMap. I have spent the last hour staring at the Tiled Demo, but it's a no go on my machine.

    I've uncommented the addons snippet in the project XML as I did with the UI line, yet I have no problems accessing imports from the UI library.

    Everything is installed:

    flixel-addons: [2.3.0]
    flixel-demos: [2.3.0]
    flixel-templates: 2.3.0 [2.3.1]
    flixel-tools: [1.2.1]
    flixel-ui: [2.2.0]
    flixel: [4.2.1]
    hxcpp: [3.4.64]
    lime-samples: [4.0.1]
    lime: 2.9.1 [4.0.3]
    openfl: 3.6.1 [4.9.2]

    I've had no problem with building the Hello World project for various platforms within VS Code and straight from the terminal using Lime.

    It's a mystery to me, but I am only on day two of messing with Haxe and HaxeFlixel. Any help is greatly appreciated. Thank you.



  • HF uses older versions of lime and openfl.

    Looks like these versions are already installed so you can just set them.

    haxelib set lime 2.9.1
    haxelib set openfl 3.6.1



  • Unfortunately that did not solve the problem.
    Thank you for you help.


  • administrators

    Is this an error you get during completion or compilation?

    If it's the former, it may just be that the .hxml file VSCode for completion has not been updated yet with flixel-addons being included (because you've been compiling to other targets). By default, the .hxml file in the Flash export folder is used.



  • This is a compilation error received both when building in VSCode and from the terminal.


  • administrators

    Does it work in demo projects that use flixel-addons (for instance the TiledEditor demo)?



  • I just did a fresh install of HaxeFlixel and I am no longer receiving the errors. I suppose something was corrupted in the previous install.

    I sincerely appreciate all the help. Thank you again.



  • I am having this same error.
    Although, I am only being thrown an error in VSCode (i.e. "Type not Found") on the "import flixel.addons.*" line.

    However, When I build and run the debug through neko, I get no errors and it compiles and runs the game fine.

    I'm assuming this is some sort of cache issue with VSCode once the addon package has been enabled in the XML. Still not sure how to get it to go away. I'd sure like to use the Intelli-text.


  • administrators

    @sk00ter Have you seen my earlier post here?

    It may just be that the .hxml file VSCode for completion has not been updated yet with flixel-addons being included (because you've been compiling to other targets). By default, the .hxml file in the Flash export folder is used.

    You may need to select Neko in your display configurations (or compile for Flash, if that one is selected).

    https://github.com/vshaxe/vshaxe/wiki/Configuration#multiple-display-configurations


Log in to reply