Type not found : FlxText



  • Hi All!
    I just got started with Flixel, and I'm already encountering an issue with the "Hello World!" tutorial. (http://haxeflixel.com/documentation/hello-world/)

    So I followed the steps (using sublime text on Mac OS X) by adding the line with FlxText, but when I tried to compile the project with flash/neko/html5 I got this error:
    source/PlayState.hx:9: characters 10-17 : Type not found : FlxText

    I installed everything, and tried downgrading lime to 2.9.1 and openfl to 3.6.1.
    Any insight on why the library doesn't seem to be working?



  • Did you import FlxText?

    import flixel.text.FlxText;
    

    How about other platforms? Do they work?



  • @DleanJeans
    I didn't import FlxText (I thought it was included in the package).
    Thank you so much for the help!


  • administrators

    This should work fine with the fully qualified path as the tutorial instructs?

    var text = new flixel.text.FlxText(0, 0, 0, "Hello World", 64);
    

Log in to reply