FlashDevelop debugging doesn't work in flash target



  • Hello,

    I have multiple problems with haxeflixel in FlashDevelop, the major one being the lack of debugging.

    Despite me setting the JAVA_HOME correctly to a fresh download of jre6 x86 and restarting the PC, it still complains that the path is wrong

    JAVA_HOME environment variable points to an invalid location: C:\Program Files (x86)\Java\jre6\bin

    Any idea how to deal with this?

    Kind regards,

    Zethariel


  • administrators

    Flash debugging in FlashDevelop was always a pain to setup correctly for me. In my experience, it's much more straightforward with VSCode and the Haxe Debug extension.



  • It's always a pain for you? That's weird. It's pretty straightforward for me. Just install Flash/HaxeDevelop and Java from its homepage then it works normally.

    Some of my suggestions:

    • Reinstall FlashDevelop and Java
    • Probably it's no different but I use HaxeDevelop
    • I have C:\ProgramData\Oracle\Java\javapath in Path system variable so maybe check it out (no JAVA_HOME)


  • @Gama11 I got VSCode and encountered the same issue. After an infuriating amount of search, I found out that the path needed forwardslashes instead of backslashes. This worked for me:

    C:\jdk1.6.0_45\bin\

    However, it doesn't work in HaxeDevelop or FlashDevelop........

    @DleanJeans I did that many, many times. It's infuriating, because everything worked before I upgraded my PC, and I don't remember the specific configuration of FlashDevelop version I had there...



  • @Zethariel said in FlashDevelop debugging doesn't work in flash target:

    @Gama11 I got VSCode and encountered the same issue. After an infuriating amount of search, I found out that the path needed forwardslashes instead of backslashes. This worked for me:

    C:\jdk1.6.0_45\bin\

    However, it doesn't work in HaxeDevelop or FlashDevelop........

    @DleanJeans I did that many, many times. It's infuriating, because everything worked before I upgraded my PC, and I don't remember the specific configuration of FlashDevelop version I had there...

    What I meant for in the path was C:/jre6/bin/ . any other variation errored. I moved my jdk just for the purpose of testing



  • @DleanJeans, can you send screenshots of your's Haxe scrrens config, pls?
    I haven't been able to run debug.

    Using Flex SDK 4.16
    Haxe 3.4.2 or FD 5.2.0.3.



  • @Maycon said in FlashDevelop debugging doesn't work in flash target:

    @DleanJeans, can you send screenshots of your's Haxe scrrens config, pls?
    I haven't been able to run debug.

    Using Flex SDK 4.16
    Haxe 3.4.2 or FD 5.2.0.3.

    I'm sorry. Not sure what you mean by screens config.
    Here's what I installed:



  • The path is C:/Program Files (x86)/Java/jre1.8.0_101 for me (without bin directory)



  • @DleanJeans , I mean to any HaxeDevelop configs for debug:

    • Tools -> Program Settings...
    • Project -> Properties -> ...

    If i don't set a SDK, Haxe return error:

    • Exception: Could not locate lib\mxmlc.jar or lib\mxmlc-cli.jar in Flex SDK.

    Setting a SDK the project run fine, but don't stop in breapoint.



  • Got it. Here you go:

    ProgramSettings

    Output

    SDK

    ClassPaths

    Build

    CompilerOptions


Log in to reply