OpenFL 6.0 is out now,what about HaxeFlixl 5.0 6.0 ?



  • Waitting for HaxeFlixel new version a long time. When release the new version?


  • administrators

    4.3.0 has been released quite recently, there's just no support for latest OpenFL yet. ;)

    There's currently two relevant open PRs:



  • @Gama11 How about the latest lime (5.3.0)..? If I install that then Flixel states:

    Flixel is currently incompatible with Lime 3.0.0 or newer

    Is there anyway we can ignore this and force a newer version of Lime instead of -3? I'm asking because i'm having some Jitter on camera follows again on a new project. Newer version of Lime just might have better SDL support and with that less Jitter. It seems to be a windows thing. I'm not seeing it on android.

    There are a couple of discusion to be found with Google on this subject, but there does not seem to be a real solution.

    Quote SruloArt here:

    1. Try making vsync to only affect cpp (if="cpp" on your project.xml in the end of the relevant line) or cancel it altogether.
    2. Try FlxG.fixedTimestep = false; FlxG.maxElapsed = 0.25.
    3. Sadly, If these options won't work I wouldn't be too surprised.

    A thread on github, an other one on google-groups, an interesting one on OpenFL (they talk about SLD there), and a post of myself. The problem just might not be Flixel or OpenFL, the problem can lay in Lime or SDL (or the way SDL is being used). Just playing around with stuff like:

    FlxG.fixedTimeStamp, FlxG.maxElapsed, FlxObject.pixelPerfectPosition, FlxObject.pixelPerfectRender, Lerp and VSync.

    Is time consuming and not fixing anything. I would love to try out a newer version of Lime, perhaps they fixed it there? :S Is it in anyways possible that i can try this? (Development version, beta version?)

    I really like HaxeFlixel and enjoy using it. But this Jitter on camera while following is driving me insane! It does not happend at the beginning of the game, but after say 10 seconds it slowly starts, after that it builds up. After 2 minutes or so its very noticeable.

    Does anyone have a solution for this?


  • Banned

    This post is deleted!

Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.