Android Development



  • Victory pose:

    0_1502790157142_DHQtJ4TWsAA4ZgF.jpg

    For anyone ELSE with this error. You need to install the latest jdk build as the others are depreciated. ALSO. You need to add the following to your Project.xml file:

    <window if="mobile" orientation="landscape" fullscreen="true" width="0" height="0" />
    <android target-sdk-version="24"/>
    <window hardware="true" allow-shaders="true" require-shaders="true" if="cpp"/>
    <window vsync="true" antialiasing="4" if="cpp" />
    <window orientation="portrait" /> || <window orientation="landscape" if="cpp"/>

    IF you are building FlappyBalt you need to comment out this line:

    <!--template path="libs/AndroidManifest.xml" rename="AndroidManifest.xml" if="android"/-->

    FlappyBalt ALSO requires the ADB to be installed and running to work.

    ALSO. During research I found that android does not like folders with commas in them. So when I tried to run the examples in the flixeldemos folder 2,2,2 it failed to run with errors. Moved them to the desktop, made those changes to their Project.xml files, and they built and ran on my phone! FINALLY.

    NOW I got new problems which I'm going to research too. For instance, after I successfully ran mode, I am unable to run my other games now. They now build but at the end they give the error:

    Failure [INSTALL_FAILED_VERSION_DOWNGRADE]

    Starting: Intent { act=android.intent.action.MAIN cmp=com.example.myapp/.MainActivity }

    And mode launches instead of any game I tell it to run.

    Anyone know why this is?

    Hope this helps somebody. Whether or not the sdk NEEDS to be 24, I tried 17 (from http://haxeflixel.com/documentation/android/ by the way) and that led to build errors so it may be just safe to use the latest sdk build you can. ALSO the adb so far was only needed for FlappyBalt. No other example has needed it yet.

    Thanks again for helping everyone!

    EDIT: Okay, If you get this, or app does not exist. Try: Cleaning project, rebuild. Delete exports, rebuild. Close, restart flashdevelop. Have one instance of flashdevelop with one game running. Uninstall app from phone. Disconnect phone. Reconnect phone and rebuild app. Try and work backwards. Uh, try those in various orders. But it's working again and I don't know what worked. Here's hoping I don't have to find out again.



  • @xhunterko

    yay!

    I think the Failure [INSTALL_FAILED_VERSION_DOWNGRADE] problem might be the package name in project.xml. Make sure they are 3 segments and unique.

    <meta title="Game Title" package="com.mydomain.GameTitle" version="1.0" company="" />


  • @dean said in Android Development:

    package="com.mydomain.GameTitle"

    Allrighty I'll try that for future compiles. Thanks again for your help!



  • @xhunterko

    You're welcome. Good luck with your game!


Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.