Is 4.3.0 stable?

  • I've been working on other frameworks/languages recently but this week I had some downtime so I decided to go back and have a look at an old Haxeflixel project that I last worked on in the beginning of the year.

    It compiled and worked, but then I did a haxelib upgrade and and it upgraded me to 4.3.0 and my game broke. Basically any attempt to set a camera's zoom would give run time error or just not show anything. I set the version back to 4.2.0 and it's all working again.

    I notice that there's no release blog entry for 4.3.0 and my google search for 'haxeflixel 4.3.0' returns virtually nothing. But the docs on talk are for 4.3 and that's the version haxelib delivers. What's going on? Is 4.3 stable and the latest? Where can I find the release notes?

  • I'm using 4.3 and it works fine. Some things about the camera changed but I didn't get any problem yet. Let us know what code is getting you in trouble.

  • FYI, there's a tweet from HaxeFlixel for the 4.3.0 release.

  • administrators

    The detailed release notes are in the changelog as usual. There wasn't a blog post for this release since there weren't really any big / exciting changes to talk about, it was just a lot of small, incremental improvements.

    We haven't had any regression reports regarding 4.3.0 so far. What's the exact runtime error were you seeing?

  • I'd doing a a couple of things that may be unusual.
    Firstly, my games size is larger than the size I am viewing it at - FlxGame 600x1000 viewed half size. My initial zoom is -1.
    Secondly I am using 2 cameras, one for the game, one for the ui, so when I start my game state I removed all the cameras, add a new game camera, then a new ui camera.

    It shows up if I leave it alone but when I try to change the zoom on the game camera I either see nothing or it gives me runtime errors - I can't paste them now as I'm at work and the project is a hobby I'm doing at home.

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.