Mac Os builds are crashing

  • I´m trying to build for Mac Os using a Mac with Os sierra 10.12.6

    My game compiles fine but it crashes after the first screen.

    I also tried compiling Mode and minimalistic TD and also crash really soon. Mode crashes when the Mo and De get to the center of the screen. Minimalistic TD crashes when I pressed the play button.

    I tried deleting all sound plays from minimalistic TD and the game works but crashes when the first enemy tries to appear with the following error:
    "No valid path was passed to the enemy! Does the tilemap provide a valid path from start to finish?
    AL lib: (EE) alc_cleanup: 1 device not closed"

    What can be the problem? I had a similar problem almost a year ago but never got to fix it. Are Mac builds working?

  • administrators

    MinimalistTD actually had a crash bug that I fixed recently (the latest haxelib release has the fix). I'm not aware of any issues with Mode. Do you get a stack trace?

  • When mode finishes compiling the following appears on the terminal:
    clang: warning: libstdc++ is deprecated; move to libc++ with a minimum deployment target of OS X 10.9 [-Wdeprecated]

    When the game crashes, it shows an error message with the following details:

  • Is there any hint about why this is happening? Is it a problem with Sierra Mac Os?

    Am I the only one that is unable to compile projects for MAC ?

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.