Lime Test Android, Again

  • This again. I reinstalled haxe to get html5 building working. Which, invariably broke the android building I had set up. Now whenever I try to build for android or do lime test android I get the following:


    I followed the set up guide displayed here:

    Again, because I thought it prudent to follow the steps so the various parts know that the various parts in the setup are there, again. After finishing that I get the same error. I check to see what folder it's pointing to and:


    I do not remember what I did last time to make it work. But I do NOT believe I need to change anything in the .hxcpp_config.xml as everything is pointing to where it was pointing before.

    Anyone have any ideas as to why this is happening and how would I go about getting android builds running again?

  • administrators

    Try downgrading hxcpp, e.g. haxelib set hxcpp 3.4.64.

  • I did switch to that version, Gamma11. Well, I am back here, again:

    Building QuizApp
    haxelib run openfl build C:\Users\Robert\Documents\Hax3\AndroidBuildsMain\QuizApp\Project.xml android
    Creating C:/Users/Robert/Documents/Hax3/AndroidBuildsMain/QuizApp/export/android/obj/obj/android-v7/__pch/haxe/hxcpp.h.gch...
    'arm-linux-androideabi-g++' is not recognized as an internal or external command,
    operable program or batch file.
    Error: Could not create PCH
    Build halted with errors (haxelib.exe).

    And I forgot how I fixed that last time.

  • administrators

    You have the Android NDK installed? That executable should be in Android NDK\toolchains\arm-linux-androideabi-<version>\prebuilt\windows\bin\arm-linux-androideabi-g++.exe.

  • Yep, I do. And I think I remembered what I did from last time I HAD to point the hxcpp_config DIRECTLY at the folder the toolchain was in. So that's a bit of a hassle. I MAY have to do something similar with Apache Ant because I am not sure where to point the config file. I am building now, but it is breaking at an Ant call. Here is what I'm getting:


    I don't believe I need a newer version of Ant, because, well, it worked last time. Unless something's changed between now and then I don't know why it wouldn't work.

    Any ideas on where I ought to point the config for Ant?

    If I remember it sometime before I get a response I'll let you know.

  • administrators

    I've never needed to configure this on my own, although my .hxcpp_config.xml does point to the correct / working locations:

    <set name="ANDROID_SETUP" value="true" />
    <set name="ANDROID_NDK_ROOT" value="C:\Development\Android NDK" />
    <set name="ANT_HOME" value="C:\Development\Apache Ant" />
    <set name="SDK_ROOT" value="c:\SDKs\" />
    <set name="ANDROID_SDK" value="C:\Development\Android SDK" />

    So it seeems that whatever automatic setup is responsible for this doesn't work for you for some reason?

  • "So it seeems that whatever automatic setup is responsible for this doesn't work for you for some reason?"

    And I have no idea why. I type in the exact command line instructions. If I have to install anything manually, I don't set it in any funny side folders. I just follow what's laid out for me and stuff breaks and I go away frustrated. I don't know what I do different or if I omit something that isn't "expected to be known". Like setting up openfl and installing things via the Android SDK Manager. Maybe my computer has quirks? I dunno.

    And every day, more and more crap gets released to google play and I can't figure this out?


  • you could try to manually remove the programs folder and then reinstall. you could also try a windows restore a save point at the time before the program was first installed.

  • I keep getting closer, I think. At least, this error feels familiar. I am building now, I really ought to take more detailed notes cause I am probably sure I changed something in the config file, or downloaded something, probably the former cause, our internet. Now I am here:


    Anyone know what this is about?

  • Okay, so building from the command line I needed to point it to the JDK, not the JRE, which is what I was pointing to.

    The problem, I think, stemmed from where you had to do manual installs and unzipping zip files into folders. That would lead to a nested folder issue of course. The reason it's a nested folder issue (in ONE case) is might be the zipper's fault in the output. Hence the correct folders not being named, which results in the auto process being interrupted, which results in the correct version of software NOT being installed do to leaving the automatic process and HAVING to go find it yourself, and of course, NOT being familiar with what you need until AFTER the fact, probably led to this problem.

    It'd be nice to see the android set up guide re-written to be more hand holdy than it is. I think it'd solve this problem.

    Anyway, I have stuff building and running again. Thank you guys very much for helping me with the problems. I appreciate it!

  • administrators

    @xhunterko said in Lime Test Android, Again:

    The problem, I think, stemmed from where you had to do manual installs and unzipping zip files into folders.

    Huh, I don't think you have to do that at any point?

  • It definitely happens when you have to download Java and the Android NDK and SDK. Neither of which are easy to navigate.

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.