lime html5 error "Could not find template file"

  • Hey folks,

    I'm trying to get into working with HaxeFlixel via the tutorial.

    However, after adding the first FlxText as per instruction, saving and going

    $ sudo lime test html5

    I immediately get this error:

    Warning: Could not find template file: html5/template
    Warning: Could not find template file: haxe
    Warning: Could not find template file: html5/hxml
    Error: Could not process argument export/html5/haxe/release.hxml (file not found)
    invalid character: /

    This seems to me like it's easily fixed if you know your way around flixel, so I figured I'd ask for help here. :)

    I've done everything as instructed in the setup.


    Edit: I've created the project via

    flixel tpl -n "FlixelTut"

    Edit2: Umm, yeah. I'm on Arch Linux and installed haxe via the arch repositories.
    What's weird tho: This exact command did work yesterday when I tried out the "Hello World!" getting started section.

    Solved: I ran $sudo haxelib remove xyz for all installed libraries and afterwards uninstalled haxe itself cleanly, then reinstalled it all from scratch. IDK what the issue was, but it works again. Weird.
    Sorry for cluttering your forum.

Log in to reply

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.