[HELP!] Cannot Build: Type not found : openfl._internal.utils.ExtraParams



  • alt text
    Full Error: --macro:1: character 1 : Type not found : openfl._internal.utils.ExtraParams

    I have just updated my HaxeFlixel (4.4.0) to 4.4.2 yesterday and it seems it creates this error now though on the previous release I could just build to HTML5, SWF and EXE just fine. Now none of them does even work and return the same error every time. Is there something I was missing or perhaps something I added that cannot be used anymore on this version? Or perhaps I installed the wrong libraries? I tried using Visual Studio Code and also Flash Develop 5.3.3 and still it does give me the same error.

    Installed libraries and other things:
    Visual Studio Code: 1.25.1 (with Lime 1.2.1 and Haxe 2.2.1)
    Flash Develop: 5.3.3
    Haxe: 4.0.0 preview 4
    Flixel: 4.4.2
    HXSCript: 2.2.0
    Lime: 6.4.0
    OpenFL: 8.3.0

    Additional Note: I also tried creating a new Haxeflixel Project using Flash Develop and it seems the Reference folder is empty. This is actually not the case the references appears just fine after re-opening the new Haxeflixel Project.

    I tried searching the said file/function and it was there.
    alt text


Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.