Issues with loading tilemaps



  • I've been following through the Getting Started Tutorial alright the last few days; I just completed trying to import the tilemap into the project and suddenly started to get all kinds of fun errors.

    I'm using visual code studio on a windows 10 machine.

    First, and probably most importantly, even though I have both flixel-addons install and uncommented the add-ons in the XML file, I get this error when I try to import the libraries to the project:

    Type not found : flixel.addons.editors.ogmo.FlxOgmoLoader
    

    This is what the import line looks like at the top of the file:

    import flixel.addons.editors.ogmo.FlxOgmoLoader;
    

    Secondly, despite having touched nothing anywhere in the libraries--I've only been adding and adjusting inside of the various source files that I need, I started to get these errors for the FlxG libraries. Again, I haven't touched them, and I got none of these errors until I tried to import a tilemap made with Ogmo.

    C:/HaxeToolkit/haxe/lib/flixel/4,4,2/flixel/FlxG.hx:608: characters 7-29 : 
    openfl.display.Application has no field config
    C:/HaxeToolkit/haxe/lib/flixel/4,4,2/flixel/FlxG.hx:614: characters 26-47 : lime.ui.Window has no field renderer
    C:/HaxeToolkit/haxe/lib/flixel/4,4,2/flixel/FlxG.hx:616: characters 9-15 : Capture variables must be lower-case
    C:/HaxeToolkit/haxe/lib/flixel/4,4,2/flixel/FlxG.hx:616: characters 17-24 : Capture variables must be lower-case
    C:/HaxeToolkit/haxe/lib/flixel/4,4,2/flixel/FlxG.hx:616: characters 17-24 : Variable     CONSOLE must appear exactly once in each sub-pattern
    The terminal process terminated with exit code: 1
    

    I.... really have no idea what caused this, or why it started to occur. As I said, I haven't even opened any of the files that aren't under source barring the XML file, and I changed only the 1 comment in there.

    Any help or advice would be greatly appreciated.


  • administrators

    The second set of errors comes from using a Flixel version that's incompatible with Lime 7. Try updating to Flixel 4.5.0.



  • Cool thanks. Upgrading fixed it, other than giving me new fun issues with Neko I didn't have prior. That also doesn't really explain why it worked right up until it suddenly stopped working; it also doesn't really explain why now Neko has issues it did not before.

    Thanks to everyone on the forum for helping me.

    Unfortunately, I think I'm going to stop trying with this. I keep running into issues and can't tell if it's the IDE, not having installed something correctly despite receiving no errors when installing, or syntax errors. Syntax errors I can at least eventually puzzle out, but the other two are pretty exhausting, and every day has felt like I'm fighting to get anything done.

    I get there are growing pains with any new environment, but I'm just tired. I want to be spending the little time off I have actually making my game. You guys have some sweet documentation and when things work, it's a pretty sweet set of libraries.


Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.