How to install Nape for Haxe 4?



  • Hey guys, I'm new to Haxe and HaxeFlixel and I'm really enjoying it. I'm planning to add a few slope collision objects to a level with Nape and I'm having a bit of trouble getting flixel running with nape version 2.0.20.

    I'm getting loads of these errors:

    
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:522: characters 18-23 : x: Custom property accessor is no longer supported, please use `get`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:522: characters 24-29 : x: Custom property accessor is no longer supported, please use `set`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:558: characters 18-23 : y: Custom property accessor is no longer supported, please use `get`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:558: characters 24-29 : y: Custom property accessor is no longer supported, please use `set`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:598: characters 23-33 : length: Custom property accessor is no longer supported, please use `get`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:598: characters 34-44 : length: Custom property accessor is no longer supported, please use `set`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:860: characters 22-31 : angle: Custom property accessor is no longer supported, please use `get`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/geom/Vec2.hx:860: characters 32-41 : angle: Custom property accessor is no longer supported, please use `set`
    /usr/local/lib/haxe/lib/nape/2,0,20/nape/dynamics/ArbiterList.hx:243: characters 23
    ...
    

    Does anyone know what I can do to fix them?


  • administrators

    There's a few fixed versions floating around, for instance https://github.com/Lythom/nape-build. Just run the following:

    haxelib git nape https://github.com/Lythom/nape-build
    

Log in to reply
 

Looks like your connection to HaxeFlixel was lost, please wait while we try to reconnect.